K40 Lightburn Homing funktioniert nicht. ERROR 8

  • Guten Morgen zusammen,

    Ich habe seit einiger Zeit einen K40 gekauft. Jetzt vor kurzem erst in Betrieb genommen..

    Ich nutze meinen K40 mit einem MKS DLC 2.0 Board.. alles funktioniert fast wie es soll.. der laser macht was er soll… rest auch..

    nur die endschalter anscheinend nicht..

    bzw sagen wir mal so..

    wenn ich x und y endschalter betaetige waehrend des verfahrens bleibt er auch stehen… also eigentlich alles okay..

    wenn ich aber in Lightburn das Homing ausfuehren moechte…passiert nichts.. und ich bekomme in der Konsole eine Fehlermeldung mit Error 8.

    eigentlich funktioniert das board super und es kann doch nicht sein, dass es daran jetzt scheitert.. Bitte um Hilfe.

  • Okay danke.. probier ich heute Abend aus. hab auf dem Board die TMC2208 v3.. die funktionieren auch wirklich gut..

    hab das ganze mit einem 1 Kilo Ohm widerstand und einem 30A Mosfet hinbekommen.. bin nach der anleitung vom frickler gegangen.. klappt wirklich super.

    nur halt das homing nicht..


    achja nachtrag.. was mir jetzt aufgefallen ist.. ich habe bei mir :

    $23 10 stehen… vielleicht liegt da mein fehler..

    hier nochmal mein settings:

    Einmal editiert, zuletzt von Tigger86 () aus folgendem Grund: nachtrag

  • Ihr müsst da gucken wie Eure Schalter angeschlossen sind!

    Dabei beachten ob invertiert oder nicht und den richtigen Zyklus.


    Je jach dem kann sogar sein der bellt weil beide Achsen gleichzeitig fahren....ich hab kein CO2 K40 und nur wenig helfen.

    Wie ich das sehe ist es bei Euch True/False und wenn ich mir das Bild anschaue könnt Ihr jede Achse einstellen.


    Sorry, aber alles wissen kann ich auch nicht : )

  • ALARM:8

    Referenzfahrt fehlgeschlagen. Der Zyklus konnte den Endschalter beim Abziehen nicht löschen. Versuchen Sie, die Abzieheinstellung zu erhöhen, oder überprüfen Sie die Verkabelung.

    ok

    Grbl 1.1g ['$' for help]

    [MSG:Check Limits]

    [MSG:'$H'|'$X' to unlock]

    [MSG:Caution: Unlocked]

    ok



    ich versteh es nicht

  • Es ist Dein GRBL...flash da mal ein 1.1h drauf.


    Die Versionen sind teilweise für X,Y und Z und bei der Version werden alle drei Endschalter abgefragt.

    Core-Systeme nur wenn zwei Motoren an einer Achse baumeln...wenn dies geflasht wurde fahren die Achsen immer schräg.

    Ab Version 1.1h und da schwirren auch viele von rum sollte X un Y für Homing funktionieren.

  • Lad mal LaserGRBL und dann verbindest Du Deinen DLC nur mit USB

    LaserGRBL starten und rechts oben im Reiter wählen: Flash Firmware


    Da wählst Du aus: GRBL 1.1h


    Kein Core oder XY...

    XY kannst Du probieren wenn die normale 1.1h nicht funktioniert.

    LaserGRBL ist kostenlos und darf man sich gern anschauen.

    Nett zum einstellen im GRBL....sehr einfach zu händeln, speichern, schreiben...

  • sorry..hatte neue endschalter bestellt weil ich dachte es würde daran liegen.. naja.. hab gbrl 1.1h drüber geflasht.. und siehe da.. dank dir.. homing funktioniert... aber nur gefühlt 2 cm und dann bleibt er einfach stehen.. obwohl kein endschalter betätigt wurde.. hab nach einem parameter gesucht..der das begrenzt ..aber nichts gefunden



    dann ist mir aber nochwas aufgefallen.. $27.. ist ja eigentlich dafür da, wenn endschalter betätigt...diesen wieder zu lösen...

    wenn ich aber $27 erhöhe auf 100..dann fährt er weiter als vorher.. gefühlt 10cm weit

  • ... ist die "100" dann evtl. die "Such-Weite" in mm, die er maximal fährt, wenn er den Endschalter sucht? - würde passen :/

    Dann mach das doch einfach mal (in mm) länger, als diejeweilige Achse in mm Weg hat ...


    Viktor

  • ja..dachte ich auch erst... aber mehr als 100 will er nicht.. und in gbrl steht das hier :


    $27 - Homing pull-off, mm

    To play nice with the hard limits feature, where homing can share the same limit switches, the homing cycle will move off all of the limit switches by this pull-off travel after it completes. In other words, it helps to prevent accidental triggering of the hard limit after a homing cycle. Make sure this value is large enough to clear the limit switch. If not, Grbl will throw an alarm error for failing to clear it.


    also eigentlich nur wenn endschalter ausgelöst wurde..um in davon wieder runterzufahren..

    aber ich raff es nicht mehr :D

  • soo.. für die geschichtsbücher.. ich hab es..


    $5 war invertiert..


    $5 - Limit pins invert, boolean

    By default, the limit pins are held normally-high with the Arduino's internal pull-up resistor. When a limit pin is low, Grbl interprets this as triggered. For the opposite behavior, just invert the limit pins by typing $5=1. Disable with $5=0. You may need a power cycle to load the change.

    NOTE: For more advanced usage, the internal pull-up resistor on the limit pins may be disabled in config.h.


    dazu fuhr homing genau in die falsche richtung..

    das war auch der grund warum $27 genau in die richtung fuhr die ich wollte.....vielen dank..

    nochmal für die firmware.. mit der alten firmware hat es nicht funktioniert..( was ein kampf ):D